Musk crashed Bitcoin. Time to buy dips?

Musk crashed Bitcoin. Time to buy dips?

What happened?

Elon Musk, Teslas founder and CEO, said the company wouldnt accept Bitcoin as payment any longer. As a result, BTC/USD dropped to $45,300, the low unseen since March.

Why has Musk done that?

He explained his actions with environmental issues: rapidly increasing use of fossil fuels for Bitcoin mining and transactions. Indeed, this problem exists. According to Citigroups report, Bitcoin mining is consuming 66 times more electricity than it did back in late 2015, and as a result, carbon emissions are increasingly rising.

Whats next?

He wont sell any of the Bitcoin Tesla already holds and whats more important, he signaled he might accept other cryptocurrencies as payment if they are less energy-intensive. Well, what would be his next #1 crypto? Maybe Dogecoin? He asked about that his followers on Twitter already: 78% said yes. There are some talks about ETH and XRP right now.

What about Bitcoin?

Musks tweet cant make an end to Bitcoin. The BTC is still the #1 cryptocurrency by the market cap and its likely to keep its uptrend in the long term. For most investors, its just a good opportunity to buy the dips.

Tech tips

The RSI indicator hasnt yet crossed the 30.00 level on the daily chart. Therefore, there is still some room to fall further, but probably the price reverses up from the current levels. If it jumps above the midline of Bollinger Bands at $55,000, the way up to $60,000 will be open. In the opposite scenario, the move below the lower trend line at $48,000 will press down the crypto to the $45,000 support.

Pay attention. To trade crypto, use the app Forex Trader.

Musk crashed Bitcoin. Time to buy dips?

Thank you for rating.
REPLY A COMMENT Cancel Reply
Please enter your name!
Please enter a correct email address!
Please enter your comment!
The g-recaptcha field is required!

Leave A Comment

Please enter your name!
Please enter a correct email address!
Please enter your comment!
The g-recaptcha field is required!